Technology Errors

Failed loading /usr/lib/php/zend/ZendOptimizer-5.3.so: cannot open shared object file: No such file or directory

Recently I upgraded PHP 5.2 to PHP 5.3 on a CentOS Linux server because of a PHP 0day and noticed an error complaining about ZendOptimizer-5.3.so which is the library loaded into PHP. After some research I found out that it doesn’t look like Zend Optimizer is available for PHP 5.3 on CentOS Linux and will not be available for PHP 5.3 period. Not a big deal in my scenario as I was using it as well as PHP eAccelerator. This error is easily resolved as long as you do not require the php-zend-optimizer package so if that is the case follow the directions below to resolve the error.

Technology Insights

Linux CentOS 5 Server: YUM Repository to Install Zend Optimizer

I recently needed to install Zend Optimizer which was required by a ZenCart addon using Zend Guard. Zend Guard encrypts some or all of a PHP application to help protect its contents from being copied or modified. So I was typically like to install everything on CentOS using the yum package manger to make sure that updates for all applications are uniform and easy to do.

The actual package that needs to be installed to install Zend OptimizerĀ is called php-zend-optimizer and isn’t readily available in many yum repositories. On a typical CentOS installation I add a couple extra yum repos including rpmforge and a repo that provides ruby based packages for CentOS. Anyhow after awhile of searching I finally located the atomic repository which did include the php-zend-optimizer package.