Code Snippets

OCS Version 0.2 Release – Cisco Router Default Password Scanner

Recently I wrote an article on cisco-ocs from Backtrack Linux and provided examples of what it did as well as a bug where if a higher privilege was provided to the vty ports it would note the router was not vulnerable. In that scenario the router was even more vulnerable because the initial login provides enable privileges. Anyhow fast forward five days and the developer, known by OverIP, reached out to me to get more details so he could fix the bug and discuss expanding Cisco OCS’s capabilities. I am happy to announce Cisco OCS version 0.2 which fixes the bug mentioned in the previous article. More details are provided below as well as information about possible future releases.