Technology Insights

Ubuntu apt-get upgrade – The following packages have been kept back

When upgrading packages on Ubuntu using the apt-get upgrade command you may notice that some packages are not upgraded. Ubuntu will not upgrade packages that could have a major impact to service on the server such as the kernel, kernel headers, MySQL packages, and various others. The packages are held back by aptitude as a safeguard to keep people from upgrading packages that might keep the server from rebooting or that might corrupt something like a database. Below we show the error in more detail and explain the command that can be run to upgrade the packages that are being held back.