Technology Insights

Find Out What Dependencies A Ruby Gem Has, Gem Dependency

Earlier this afternoon I was working on a development server that has a web server, a PostgreSQL database, Ruby, and rubygems installed on it. I was curious to find out if a specific gem I was about to install had any dependencies or other gems that would also be installed as dependents of the gem I wanted to test. Below I describe how to find out the dependencies of a specific gem by querying the remote server but also how to download a specific gem version to see what gems are dependents.

Technology Insights

Gem Update Rubygems-Update Not Updating The Gem Command

Earlier when attempting to install the request-log-analyzer gem on a CentOS Linux server I ran into some issues. I noticed that on one server I was able to install the request-log-analyzer gem without issue but on another server running the same version of CentOS and Ruby as the first server the attempt to install request-log-analyzer returned an error. The error was that the gem required a newer version of another gem.

Technology Insights

Install a Ruby Gem From Your Local Linux Server

Installing a gem locally is extremelly easy if you follow the steps below. I was recently in a situation where I had to upgrade a gem quickly to resolve a bug but the latest version of the gem located on http://gems.rubyforge.org was older than what was necessary. You need to locate the .gem file for the gem that needs to be installed and get a copy on the local server. In my case I happened to have a gem server that had ben installed but the web access was down at the moment so I SCP’d (secure copy) it to the local server and placed it in /usr/local/src.

Once you have the gem moved onto the local server issue the below command to install.

Technology Errors

gem install data_fabric ERROR: Error installing data_fabric: data_fabric requires RubyGems version = 1.2

When initially attempting to install the data_fabric gem I was getting the below error. Error: gem install data_fabric ERROR: Error installing data_fabric: data_fabric requires RubyGems version = 1.2 It is possible to get this error if you have upgraded to rubygems 1.3 and you are attempting to install data_fabric (version: 1.0.1 or below). If you…