Technology Errors

Error: Missing Dependency: is needed by package python26-2.6.2-2.i386

One of the annoying things about CentOS Linux is the current dependency on Python version 2.4. Typically I install Python version 2.6 and compile new programs using the 2.6 version of python instead of the 2.4 version. Recently on a server I had just installed CentOS 5.4 on I had a dependency issue when attempting to install python version 2.6 from the CHL repository. Below I display the error and describe how to install the libffi package on CentOS Linux.

Technology Insights

CHL Yum Repository Not Working On 64-Bit CentOS Linux

Recently we installed a development server running 64-Bit (x86_64) CentOS Linux. One of the things we needed to install was Python version 2.6 without overwriting the default Python version 2.4 on the server. The reason for not wanting to overwrite the default Python version is because other packages such as the Yum Package Manager depend on Python version 2.4. Anyhow in the past I have used the CHL repository for the Python version 2.6 packages because they are compiled to run as python26 or python2.6 and using the python command still launches python 2.4. Anyhow after installing the CHL yum repository as noted here we had issues installing python version 2.6 which I describe below along with how to resolve the issue.

Technology Insights

How To Install Python 2.6 On CentOS 5 Without Breaking Yum

I recently was installing Django for a test project and needed to upgrade Python on a CentOS server to 2.6. The current revisions available via yum on CentOS are 2.4. The yum package manager requires Python 2.4 still to function properly so upgrading Python to 2.6 manually will break the CentOS yum package manager. After a little bit of research I found a yum repository that would allow you to install Python version 2.6 in parallel to Python version 2.4. Below I explain how to install the new Python version, not break the yum package manager, and modify a Django project that references Python to use the 2.6 version instead of the 2.4 version.