Technology Insights

How to Install Skype in Ubuntu 10.04 Lucid Lynx

I just got around to downloading The new LTS release from Ubuntu which is 10.04. I have to admit as a long time Gentoo Linux user I am very impressed with the speed of 10.04. There are some annoying bugs but I am working on sorting those out and I will try to post some of the results. So this morning I needed to get Skype going so i decided to whip up a quick piece on installing Skype on the newest Ubuntu.

Technology Insights

Gentoo: Paste Into Vi Issue, Each Line Gains More Spaces To The Left

My Linux distribution of choice is CentOS so that is where I typically spend time. Recently though I have been working for a project that runs on a Gentoo Linux server. So far I really like Gentoo though there are some things that I am used to that are totally different. One minor issues I have had is how vi/vim (vi IMproved) handles text that is pasted into it. Every time I was pasting data into a file I was editing with vi. Initially I thought it must have been some odd formatting coming from the file I was copying the text from however I ruled this out quickly when I pasted into notepad first to remove all formatting and then into vi and sure enough the spaces on the left still existed. Below I explain the issue, provide an image of a shell window showing the issue, and how to resolve the problem.

Code Snippets

Postfix Logrotate Script For Gentoo Linux

Working on a friends server earlier this morning I noticed that he had logrotate configured but he did not have a configuration file for Postfix. Below is the quick one I whipped up for his environment including a brief explanation of each line of the configuration file below the script. Following the explanation of the various configurations is the command to actually force logrotate to run in debug mode so you can see what happens.

Technology Insights

Failed to emerge dev-python/beautifulsoup-3.1.0.1-r1

This morning I decided to make the big switch to Python 3.0 on my Gentoo Laptop. I have been avoiding it since there are some changes to 3.0 that are not backwards compatible with scripts and tool written in 2.6. The emerge of Python 3.0 went fine but I had some issues with beauitfulsoup which is a python dependency in many tools including fast-track which is a great tool written by my friend Dave Kennedy (ReL1k). As always if you have any questions regarding this or any other issues please make a post in the Question section of the site.