Technology Errors

dhcp3-server: Depends: dhcp3-common (= 3.1.3-2ubuntu3.2) but 3.1.3-2ubuntu3.3 is to be installed

When attempting to install dhcp3-server on BackTrack Linux version 5 R3 you likely will run into a dependency error. This error was received on a brand new install of BT5r3 so the issue would be the same on any current install. Below I describe the error installing dhcp3-server on Backtrack in more detail as well as how to easily fix the problem. It should also be noted that this will likely fix other dependency issues you might have run into with a fresh install of BT5r3.

Technology Insights

IBM Java SDK Install Error: Failed dependencies: /usr/lib64/libstdc++.so.5 is needed by ibm-java-x86_64-sdk-6.0-9.1.x86_64

While setting up a websphere test server I ran into a minor dependency error during the beginning of installing the necessary packages for websphere. The IBM Java SDK RPM on CentOS 6 was complaining about a failed dependency of a libstdc++ library. The RPM I was attempting to install required libstdc++.so.5 and CentOS 6 has libstdc++.so.6 installed by default. All that is required is to install the libstdc++ compat RPM. The information below describes the error in more detail, how I located the package that installed the necessary file(s), and an example of installing the needed package.

Technology Errors

Error: Missing Dependency: libffi.so.5 is needed by package python26-2.6.2-2.i386

One of the annoying things about CentOS Linux is the current dependency on Python version 2.4. Typically I install Python version 2.6 and compile new programs using the 2.6 version of python instead of the 2.4 version. Recently on a server I had just installed CentOS 5.4 on I had a dependency issue when attempting to install python version 2.6 from the CHL repository. Below I display the error and describe how to install the libffi package on CentOS Linux.

Technology Insights

Failed to emerge dev-python/beautifulsoup-3.1.0.1-r1

This morning I decided to make the big switch to Python 3.0 on my Gentoo Laptop. I have been avoiding it since there are some changes to 3.0 that are not backwards compatible with scripts and tool written in 2.6. The emerge of Python 3.0 went fine but I had some issues with beauitfulsoup which is a python dependency in many tools including fast-track which is a great tool written by my friend Dave Kennedy (ReL1k). As always if you have any questions regarding this or any other issues please make a post in the Question section of the site.

Technology Errors

Error: Missing dependency: libevent-1.1a.so.1 is needed by package nfs-utils

When performing a “yum update” I received the following error which deals with a library needed by the nfs-utils package on CentOS.

Error: Missing dependency: libevent-1.1a.so.1 is needed by package nfs-utils

On this machine NFS is not needed so I took the following steps to complete the “yum update”.

  1. Remove nfs-utils: First remove nfs-utils by issuing the below command.
  2. bash

    1. yum remove nfs-utils