Technology Errors

ExtractionError: Can’t extract file(s) to egg cache, [Errno 13] Permission denied: ‘/root/.python-eggs’

I received an error when configuring a Django run site for the first time. The setup included installing and configuring some items I am not so familiar with such as mod_python, Django, and other Python items. I finally started making some progress and when I initially launched a test site I received the below errors in the debug output.

Short Error: ExtractionError: Can’t extract file(s) to egg cache

Technology Errors

error: invalid Python installation: unable to open /usr/lib/python2.4/config/Makefile (No such file or directory)

I received the error below when attempting to use easy_install to add the html5lib package on a server for a client. I assumed all of the necessary python packages were installed since easy_install was already available via python-setuptools-devel. After a quick investigation I noticed that the python-devel package was not installed. This can easily be installed on CentOS Linux using yum with the directions below.

Technology Insights

Install html5lib And markdown2 Python Packages On CentOS Linux

I needed to install some python related packages for a project I was testing out. The particular project required html5lib and markdown2 to be installed using the easy_install command. First make sure that you have the python-setuptools packages installed so you can use the easy_install command. If you do not have this package installed you can follow the directions here to get easy_install working. Once the easy_install command is working properly run the commands below to install html5lib and markdown2.

Technology Insights

Failed to emerge dev-python/beautifulsoup-3.1.0.1-r1

This morning I decided to make the big switch to Python 3.0 on my Gentoo Laptop. I have been avoiding it since there are some changes to 3.0 that are not backwards compatible with scripts and tool written in 2.6. The emerge of Python 3.0 went fine but I had some issues with beauitfulsoup which is a python dependency in many tools including fast-track which is a great tool written by my friend Dave Kennedy (ReL1k). As always if you have any questions regarding this or any other issues please make a post in the Question section of the site.

Technology Insights

Using an Adobe Exploit in a Email Attack

This attack takes advantage of a vulnerability in Adobe Reader and Acrobat. The official release is here. Adobe has been informed of this vulnerability for well over a month now and has issued a statement that it will release a fix on January 14th. It is a scary thought that this exploit will be live and in the wild for almost 2 months before Adobe decides to fix it.  I am making this post in order to make people aware of how such a attack can take place and how easy it is to implement.