When initially attempting to install the data_fabric gem I was getting the below error.
gem install data_fabric
ERROR: Error installing data_fabric:
data_fabric requires RubyGems version = 1.2
It is possible to get this error if you have upgraded to rubygems 1.3 and you are attempting to install data_fabric (version: 1.0.1 or below). If you have access to the gem server you are installing from them just update the data_faric gem on that server but if not then add the rubyforge gem repository as follows.
gem install –source http://gems.rubyforge.org/ data_fabric -v 1.0.2
That should do the trick.