Technology Insights

Error: Missing Dependency: cvsps is needed by package git-cvs-1.7.2.2-1.el5.rf.i386

During an attempt to update Git on a CentOS Linux server via the Yum Package manager this evening I ran into a dependency error. The newer Git package has a dependency of Git-CVS package which also has a dependency of CVSPS package. ┬áSo initially when I installed Git it didn’t require these packages so I never ran into an error. Below I show the error displayed when attempting to upgrade git via yum followed by how I resolved the issue installing the EPEL repository.