Technology Errors

CentOS Linux: Can’t install RMagick 2.7.0. Can’t find Magick-config

While prepping a development server earlier this afternoon I ran into an issue installing the rmagick gem. This was one of a list of 30 or so gems required by a Ruby project that was being installed onto the development server. I thought initially something else was wrong because I had run into this issue before but I thought I had installed ImageMagick via the yum package manager to resolve the problem. Anyhow after verifying ImageMagick was installed I still had the same issue on the development CentOS Linux server. Below I describe the error in detail along with what was done to resolve the issue.