Archive for April 2nd, 2009

Another error during an attempt to compile PHP via the Litespeed web admin console dealt with MySQL library versions. I had MySQL installed and operational on the server so I wasn’t immediately sure what the issue was.

Error:configure: error: wrong mysql library version or lib not found. Check config.log for more information.

After looking further into the problem I realized that I needed to install the MySQL development package via yum. Issue the below command to resolve this issue.

yum install mysql-devel

After installing this package I was able to compile PHP using the Litespeed web admin console.

DeliciousStumbleUponDiggTwitterFacebookRedditLinkedInEmail
Tags: , , , , , , ,

Comments No Comments »

I received the following error in the log when attempting to compile PHP in the Litespeed web admin.

Error: configure: error: xml2-config not found. Please check your libxml2 installation.

Resolving this error is easy by installing libxml2-devel via yum as shown below.

yum install libxml2-devel
DeliciousStumbleUponDiggTwitterFacebookRedditLinkedInEmail
Tags: , , , , ,

Comments No Comments »

I was trying to install and work with Simple Ticket, a rails customer support ticket system, which required a really old version of rails. The goal was to have an easy ticketing system as a temporary solution until a permanent system could be put in place later. So one of the requirements for installing Simple Ticket was to freeze rails at version 1.1.6.

So during the attempt to freeze rails at version 1.1.6 I received the below error.

Command:

rake rails:freeze:edge TAG=rel_1-1-6

Read the rest of this entry »

DeliciousStumbleUponDiggTwitterFacebookRedditLinkedInEmail
Tags: , , , , , ,

Comments No Comments »